What’s Vulnerable › Vulnerabilities
CVE-2026-42180: Lemmy: SSRF in /api/v3/post via Webmention dispatch
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-10-26
- Weakness: CWE-918
Description
Lemmy is a link aggregator and forum for the fediverse. Prior to version 0.19.18, Lemmy allows an authenticated low-privileged user to create a link post through POST /api/v3/post. When a post is created in a public community, the backend asynchronously sends a Webmention to the attacker-controlled link target. The submitted URL is checked for syntax and scheme, but the audited code path does not reject loopback, private, or link-local destinations before the Webmention request is issued. This lets a normal user trigger server-side HTTP requests toward internal services. This issue has been patched in version 0.19.18.
Affected products
- LemmyNet lemmy: before 0.19.18
References
- https://github.com/LemmyNet/lemmy/releases/tag/0.19.18
- https://github.com/LemmyNet/lemmy/security/advisories/GHSA-3jvj-v6w2-h948
- https://github.com/LemmyNet/lemmy/security/advisories/GHSA-3jvj-v6w2-h948
Get alerted when CVE-2026-42180 or the next vulnerability affects your stack