What’s Vulnerable › Vulnerabilities
CVE-2026-42189: Russh: Pre-auth DoS via unbounded allocation in keyboard-interactive auth
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-08 · updated 2026-10-26
- Weakness: CWE-770
Description
Russh is a Rust SSH client & server library. Prior to version 0.60.1, a pre-authentication denial-of-service vulnerability exists in the server's keyboard-interactive authentication handler. A malicious client can crash any russh-based server that implements keyboard-interactive auth (e.g., for 2FA/TOTP) with a single malformed packet, requiring no credentials. This issue has been patched in version 0.60.1.
Affected products
- warp-tech russh: before 0.60.1 — fixed in 0.60.1
- warp-tech warpgate: before 0.23.1 — fixed in 0.23.1
How to fix
Upgrade to a fixed version: warp-tech russh 0.60.1; warp-tech warpgate 0.23.1. Check the vendor advisory for mitigations.
References
- https://github.com/Eugeny/russh/commit/6c3c80a9b6d60763d6227d60fa8310e57172a4d1
- https://github.com/Eugeny/russh/releases/tag/v0.60.1
- https://github.com/Eugeny/russh/security/advisories/GHSA-f5v4-2wr6-hqmg
- https://github.com/Eugeny/russh/security/advisories/GHSA-f5v4-2wr6-hqmg
Get alerted when CVE-2026-42189 or the next vulnerability affects your stack