What’s Vulnerable › Vulnerabilities
CVE-2026-42203: LiteLLM: Server-Side Template Injection in /prompts/test endpoint
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-10-26
- Weakness: CWE-1336
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.80.5 to before version 1.83.7, the POST /prompts/test endpoint accepted user-supplied prompt templates and rendered them without sandboxing. A crafted template could run arbitrary code inside the LiteLLM Proxy process. The endpoint only checks that the caller presents a valid proxy API key, so any authenticated user could reach it. Depending on how the proxy is deployed, this could expose secrets in the process environment (such as provider API keys or database credentials) and allow commands to be run on the host. This issue has been patched in version 1.83.7.
Affected products
- BerriAI litellm: from 1.80.5 before 1.83.7 — fixed in 1.83.7
How to fix
Upgrade to a fixed version: BerriAI litellm 1.83.7. Check the vendor advisory for mitigations.
References
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable
- https://github.com/BerriAI/litellm/security/advisories/GHSA-xqmj-j6mv-4862
- https://access.redhat.com/security/cve/CVE-2026-42203
- https://bugzilla.redhat.com/show_bug.cgi?id=2467917
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42203.json
Get alerted when CVE-2026-42203 or the next vulnerability affects your stack