What’s Vulnerable › Vulnerabilities
CVE-2026-42208: BerriAI LiteLLM SQL Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-05-08
- EPSS: 89.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-08 · updated 2026-10-26
- Weakness: CWE-89
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.
Affected products
- BerriAI litellm: from 1.81.16 before 1.83.7 — fixed in 1.83.7
How to fix
Upgrade to a fixed version: BerriAI litellm 1.83.7. Check the vendor advisory for mitigations.
References
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable
- https://github.com/BerriAI/litellm/security/advisories/GHSA-r75f-5x8p-qvmc
- https://access.redhat.com/security/cve/CVE-2026-42208
- https://bugzilla.redhat.com/show_bug.cgi?id=2463965
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42208.json
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42208
Get alerted when CVE-2026-42208 or the next vulnerability affects your stack