What’s Vulnerable › Vulnerabilities
CVE-2026-42214: Improper Control of Generation of Code ('Code Injection') in dail8859/NotepadNext
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-07 · updated 2026-10-26
- Weakness: CWE-94
Description
Notepad Next is a cross-platform, reimplementation of Notepad++. Prior to version 0.14, NotepadNext's detectLanguageFromExtension() function interpolates a file's extension directly into a Lua script without sanitization. An attacker can craft a filename whose extension contains Lua code, which executes automatically when the victim opens the file in NotepadNext. Because luaL_openlibs() is called unconditionally, the full os, io, and package libraries are available to the injected code, enabling arbitrary command execution. This issue has been patched in version 0.14.
Affected products
- dail8859 NotepadNext: before 0.14 — fixed in 0.14
How to fix
Upgrade to a fixed version: dail8859 NotepadNext 0.14. Check the vendor advisory for mitigations.
References
- https://github.com/dail8859/NotepadNext/commit/f3ca1b10aca52f05fd7f4f5ebf9b566d6cd95ccc
- https://github.com/dail8859/NotepadNext/releases/tag/v0.14
- https://github.com/dail8859/NotepadNext/security/advisories/GHSA-m5fq-c9x5-w54g
- https://github.com/dail8859/NotepadNext/security/advisories/GHSA-m5fq-c9x5-w54g
Get alerted when CVE-2026-42214 or the next vulnerability affects your stack