What’s Vulnerable › Vulnerabilities
CVE-2026-42215: GitPython: Command injection via Git options bypass
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-07 · updated 2026-06-17
- Weakness: CWE-78
Description
GitPython is a python library used to interact with Git repositories. From version 3.1.30 to before version 3.1.47, GitPython blocks dangerous Git options such as --upload-pack and --receive-pack by default, but the equivalent Python kwargs upload_pack and receive_pack bypass that check. If an application passes attacker-controlled kwargs into Repo.clone_from(), Remote.fetch(), Remote.pull(), or Remote.push(), this leads to arbitrary command execution even when allow_unsafe_options is left at its default value of False. This issue has been patched in version 3.1.47.
Affected products
- gitpython-developers GitPython: from 3.1.30 before 3.1.47 — fixed in 3.1.47
How to fix
Upgrade to a fixed version: gitpython-developers GitPython 3.1.47. Check the vendor advisory for mitigations.
References
- https://github.com/gitpython-developers/GitPython/releases/tag/3.1.47
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-rpm5-65cw-6hj4
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-rpm5-65cw-6hj4
Get alerted when CVE-2026-42215 or the next vulnerability affects your stack