What’s Vulnerable › Vulnerabilities
CVE-2026-42221: nginx-ui: Unauthenticated First-Run Installer Allows Remote Initial Admin Claim
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-04 · updated 2026-10-26
- Weakness: CWE-306
Description
Nginx UI is a web user interface for the Nginx web server. From version 2.0.0 to before version 2.3.8, an unauthenticated network attacker can claim the initial administrator account on a fresh nginx-ui instance during the first-run setup window. The public /api/install endpoint is reachable without authentication, and the request-encryption flow only protects payload confidentiality in transit; it does not authenticate who is allowed to perform installation. A remote attacker who reaches the service before the legitimate operator can set the admin email, username, and password, causing permanent initial-instance takeover. This issue has been patched in version 2.3.8.
Affected products
- 0xJacky nginx-ui: from 2.0.0 before 2.3.8 — fixed in 2.3.8
How to fix
Upgrade to a fixed version: 0xJacky nginx-ui 2.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.8
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-h27v-ph7w-m9fp
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-h27v-ph7w-m9fp
Get alerted when CVE-2026-42221 or the next vulnerability affects your stack