What’s Vulnerable › Vulnerabilities
CVE-2026-42223: nginx-ui: Settings API Exposes Protected Secrets
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-04 · updated 2026-10-26
- Weakness: CWE-200
Description
Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.8, the GetSettings API handler (api/settings/settings.go:24-65) serializes all settings structs to JSON and returns them to authenticated users. Many sensitive fields are tagged with protected:"true" - however, this tag is only enforced during writes (via ProtectedFill in SaveSettings) and is completely ignored during reads. This exposes 40+ protected fields including JwtSecret (enabling auth token forgery), NodeSecret (enabling cluster node impersonation), OIDC ClientSecret (enabling OAuth account takeover), and the IP whitelist configuration. This issue has been patched in version 2.3.8.
Affected products
- 0xJacky nginx-ui: before 2.3.8 — fixed in 2.3.8
How to fix
Upgrade to a fixed version: 0xJacky nginx-ui 2.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.8
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-q4w7-56hr-83rm
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-q4w7-56hr-83rm
Get alerted when CVE-2026-42223 or the next vulnerability affects your stack