What’s Vulnerable › Vulnerabilities
CVE-2026-42225: GnuTLS backend silently skips certificate chain verification when verify_peer is false
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-07 · updated 2026-10-26
- Weakness: CWE-295
Description
PJSIP is a free and open source multimedia communication library written in C. Prior to version 2.17, on GnuTLS builds, the SIP TLS transport (sip_transport_tls) can accept connections with invalid or untrusted certificates even when the application explicitly enables certificate verification via verify_server = PJ_TRUE or verify_client = PJ_TRUE. This issue has been patched in version 2.17.
Affected products
- teluu pjsip: before 2.17 — fixed in 2.17
How to fix
Upgrade to a fixed version: teluu pjsip 2.17. Check the vendor advisory for mitigations.
References
- https://github.com/pjsip/pjproject/commit/ef684252bb62b0716675b6e99ad7fe4c90e28920
- https://github.com/pjsip/pjproject/releases/tag/2.17
- https://github.com/pjsip/pjproject/security/advisories/GHSA-x2fv-6j6c-pxmx
Get alerted when CVE-2026-42225 or the next vulnerability affects your stack