What’s Vulnerable › Vulnerabilities
CVE-2026-42246: net-imap vulnerable to STARTTLS stripping via invalid response timing
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-09 · updated 2026-08-24
- Weakness: CWE-392
Description
Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.3.10, 0.4.24, 0.5.14, and 0.6.4, a man-in-the-middle attacker can cause Net::IMAP#starttls to return "successfully", without starting TLS. This issue has been patched in versions 0.3.10, 0.4.24, 0.5.14, and 0.6.4.
Affected products
- ruby-lang Net::Imap: before 0.3.10; from 0.4.0 before 0.4.24; from 0.5.0 before 0.5.14; from 0.6.0 before 0.6.4 — fixed in 0.3.10, 0.4.24, 0.5.14, 0.6.4
How to fix
Upgrade to a fixed version: ruby-lang Net::Imap 0.3.10, 0.4.24, 0.5.14, 0.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/ruby/net-imap/commit/0ede4c40b1523dfeaf95777b2678e54cc0fd9618
- https://github.com/ruby/net-imap/commit/24a4e770b43230286a05aa2a9746cdbb3eb8485e
- https://github.com/ruby/net-imap/commit/97e2488fb5401a1783bddd959dde007d9fbce42c
- https://github.com/ruby/net-imap/commit/f79d35bf5833f186e81044c57c843eda30c873da
- https://github.com/ruby/net-imap/releases/tag/v0.3.10
- https://github.com/ruby/net-imap/releases/tag/v0.4.24
- https://github.com/ruby/net-imap/releases/tag/v0.5.14
- https://github.com/ruby/net-imap/security/advisories/GHSA-vcgp-9326-pqcp
- https://access.redhat.com/errata/RHSA-2026:33462
- https://access.redhat.com/errata/RHSA-2026:33512
- https://access.redhat.com/errata/RHSA-2026:33514
- https://access.redhat.com/errata/RHSA-2026:33515
Get alerted when CVE-2026-42246 or the next vulnerability affects your stack