What’s Vulnerable › Vulnerabilities
CVE-2026-42256: net-imap: Denial of service via high iteration count for `SCRAM-*` authentication
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-09 · updated 2026-07-24
- Weakness: CWE-770
Description
Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. From versions 0.4.0 to before 0.4.24, 0.5.0 to before 0.5.14, and 0.6.0 to before 0.6.4, when authenticating a connection with SCRAM-SHA1 or SCRAM-SHA256, a hostile server can perform a computational denial-of-service attack on the client process by sending a big iteration count value. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.
Affected products
- ruby-lang Net::Imap: from 0.4.0 before 0.4.24; from 0.5.0 before 0.5.14; from 0.6.0 before 0.6.4 — fixed in 0.4.24, 0.5.14, 0.6.4
How to fix
Upgrade to a fixed version: ruby-lang Net::Imap 0.4.24, 0.5.14, 0.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/ruby/net-imap/commit/158d0b505074397cdb5ceb58935e42dd2bcfa612
- https://github.com/ruby/net-imap/commit/808001bc45c06f7297a7e96d341279e041a7f7f4
- https://github.com/ruby/net-imap/commit/99f59eab6064955a23debd95410263ad144df758
- https://github.com/ruby/net-imap/releases/tag/v0.4.24
- https://github.com/ruby/net-imap/releases/tag/v0.5.14
- https://github.com/ruby/net-imap/releases/tag/v0.6.4
- https://github.com/ruby/net-imap/security/advisories/GHSA-87pf-fpwv-p7m7
Get alerted when CVE-2026-42256 or the next vulnerability affects your stack