What’s Vulnerable › Vulnerabilities
CVE-2026-42258: net-imap: Command Injection via unvalidated Symbol inputs
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-09 · updated 2026-08-24
- Weakness: CWE-77
Description
Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.4.24, 0.5.14, and 0.6.4, symbol arguments to commands are vulnerable to a CRLF Injection / IMAP Command injection via Symbol arguments passed to IMAP commands. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.
Affected products
- ruby-lang Net::Imap: before 0.4.24; from 0.5.0 before 0.5.14; from 0.6.0 before 0.6.4 — fixed in 0.4.24, 0.5.14, 0.6.4
How to fix
Upgrade to a fixed version: ruby-lang Net::Imap 0.4.24, 0.5.14, 0.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/ruby/net-imap/releases/tag/v0.4.24
- https://github.com/ruby/net-imap/releases/tag/v0.5.14
- https://github.com/ruby/net-imap/releases/tag/v0.6.4
- https://github.com/ruby/net-imap/security/advisories/GHSA-75xq-5h9v-w6px
- https://access.redhat.com/errata/RHSA-2026:33462
- https://access.redhat.com/errata/RHSA-2026:33512
- https://access.redhat.com/errata/RHSA-2026:33514
- https://access.redhat.com/errata/RHSA-2026:33515
- https://access.redhat.com/errata/RHSA-2026:33540
- https://access.redhat.com/errata/RHSA-2026:33565
- https://access.redhat.com/errata/RHSA-2026:33576
- https://access.redhat.com/errata/RHSA-2026:33577
Get alerted when CVE-2026-42258 or the next vulnerability affects your stack