What’s Vulnerable › Vulnerabilities
CVE-2026-42268: ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-12 · updated 2026-10-26
- Weakness: CWE-191
Description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
Affected products
- owasp-modsecurity ModSecurity: from 3.0.0 before 3.0.15 — fixed in 3.0.15
How to fix
Upgrade to a fixed version: owasp-modsecurity ModSecurity 3.0.15. Check the vendor advisory for mitigations.
References
- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-vwr3-7x7g-7p9w
- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-vwr3-7x7g-7p9w
Get alerted when CVE-2026-42268 or the next vulnerability affects your stack