What’s Vulnerable › Vulnerabilities
CVE-2026-42269: countly-server: Path Traversal in delete_import Endpoint Allows Arbitrary File and Directory Deletion
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-16 · updated 2026-10-16
- Weakness: CWE-22
Description
countly-server is the server-side part of Countly, a product analytics solution. Prior to 24.05.50 and 25.03.44, the authenticated data-migration deletion route in plugins/data_migration/api/api.js passes the user-controlled exportid to clean_up_data without path validation. plugins/data_migration/api/data_migration_helper.js concatenates that identifier into a path resolved outside the intended import directory and calls remove recursively, allowing an application administrator or user with migration permission to delete writable files or directory trees and cause data loss or service disruption. This issue is fixed in versions 24.05.50 and 25.03.44.
Affected products
- countly-server: before 24.05.50; from 25.03, < 25.03.44
References
- https://github.com/Countly/countly-server/blob/master/CHANGELOG.md#version-250344
- https://github.com/Countly/countly-server/commit/764e2a1d86f9af600113f77422d520338c214229
- https://github.com/Countly/countly-server/commit/b652ee8dafa91602705004d0edb602a91a0d845e
- https://github.com/Countly/countly-server/releases/tag/24.05.50
- https://github.com/Countly/countly-server/releases/tag/25.03.44
- https://github.com/Countly/countly-server/security/advisories/GHSA-5pmc-54j6-jcgq
Get alerted when CVE-2026-42269 or the next vulnerability affects your stack