What’s Vulnerable › Vulnerabilities
CVE-2026-42271: BerriAI LiteLLM Command Injection Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-06-08
- EPSS: 91.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-08 · updated 2026-10-26
- Weakness: CWE-77
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.
Affected products
- BerriAI litellm: from 1.74.2 before 1.83.7 — fixed in 1.83.7
- Red Hat OpenShift AI 2.25: from 2.25 before 2.25.8; from 3.3 before 3.3.4; 3.4 — fixed in 2.25.8, 3.3.4
How to fix
Upgrade to a fixed version: BerriAI litellm 1.83.7; Red Hat OpenShift AI 2.25 2.25.8, 3.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable
- https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g
- https://access.redhat.com/errata/RHSA-2026:27784
- https://access.redhat.com/errata/RHSA-2026:28960
- https://access.redhat.com/errata/RHSA-2026:30056
- https://access.redhat.com/security/cve/CVE-2026-42271
- https://bugzilla.redhat.com/show_bug.cgi?id=2467924
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42271.json
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42271
Get alerted when CVE-2026-42271 or the next vulnerability affects your stack