What’s Vulnerable › Vulnerabilities
CVE-2026-42280: Improper Permission Checking in Auth.js SDK
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-10-26
- Weakness: CWE-863
Description
Auth0.js is a client-side JavaScript library for Auth0. From 8.11.0 to 9.32.0, under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. This vulnerability is fixed in 10.0.0.
Affected products
- auth0.js: from 8.11.0 before 10.0.0 — fixed in 10.0.0
How to fix
Upgrade to a fixed version: auth0.js 10.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-42280 or the next vulnerability affects your stack