What’s Vulnerable › Vulnerabilities
CVE-2026-42298: Postiz: Arbitrary Code Execution and Token Exfiltration in pr-docker-build.yml via untrusted Dockerfile.dev
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-07-24
- Weakness: CWE-94
Description
Postiz is an AI social media scheduling tool. Prior to commit da44801, a "Pwn Request" vulnerability in the Build and Publish PR Docker Image workflow (.github/workflows/pr-docker-build.yml) allows any unauthenticated user to execute arbitrary code during the Docker build process and exfiltrate a highly privileged GITHUB_TOKEN (write-all permissions). This can be achieved simply by opening a Pull Request from a fork with a maliciously modified Dockerfile.dev. This issue has been patched via commit da44801.
Affected products
- gitroomhq postiz-app: before 2.21.7 — fixed in 2.21.7
How to fix
Upgrade to a fixed version: gitroomhq postiz-app 2.21.7. Check the vendor advisory for mitigations.
References
- https://github.com/gitroomhq/postiz-app/commit/da448012dd87e94944cbe83a38e7fd023269ec46
- https://github.com/gitroomhq/postiz-app/security/advisories/GHSA-v975-9h5p-xhm4
Get alerted when CVE-2026-42298 or the next vulnerability affects your stack