What’s Vulnerable › Vulnerabilities
CVE-2026-42301: Improper Input Validation leading to Improper Control of Generation of Code ('Code Injection') in pyp2spec
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-09 · updated 2026-07-24
- Weakness: CWE-20
Description
pyp2spec generates working Fedora RPM spec file for Python projects. Prior to version 0.14.1, pyp2spec was writing PyPI package metadata (e.g. the summary field) into the generated spec file without escaping RPM macro directives. When a packager then runs rpmbuild, those directives get evaluated, so a malicious package can execute arbitrary commands on the build machine. This issue has been patched in version 0.14.1.
Affected products
- befeleme pyp2spec: before 0.14.1
References
- https://github.com/befeleme/pyp2spec/releases/tag/v0.14.1
- https://github.com/befeleme/pyp2spec/security/advisories/GHSA-r35x-v8p8-xvhw
Get alerted when CVE-2026-42301 or the next vulnerability affects your stack