What’s Vulnerable › Vulnerabilities
CVE-2026-42302: FastGPT: Unauthenticated Remote Code Execution (RCE) via code-server Misconfiguration in agent-sandbox
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-07-24
- Weakness: CWE-306
Description
FastGPT is an AI Agent building platform. From version 4.14.10 to before version 4.14.13, the agent-sandbox component of FastGPT is vulnerable to unauthenticated Remote Code Execution (RCE). The startup script entrypoint.sh initializes code-server with the --auth none flag and binds the service to all network interfaces (0.0.0.0:8080). This configuration allows any user with network access to the port to bypass authentication and gain full control over the sandbox environment. This issue has been patched in version 4.14.13.
Affected products
- labring FastGPT: from 4.14.10, < 4.14.13
References
- https://github.com/labring/FastGPT/commit/9d1cafce9241430fb5bcdd646455055c5f4ae0a4
- https://github.com/labring/FastGPT/pull/6781
- https://github.com/labring/FastGPT/releases/tag/v4.14.13
- https://github.com/labring/FastGPT/security/advisories/GHSA-34rc-438g-7w78
- https://github.com/labring/FastGPT/security/advisories/GHSA-34rc-438g-7w78
Get alerted when CVE-2026-42302 or the next vulnerability affects your stack