What’s Vulnerable › Vulnerabilities
CVE-2026-42311: Pillow: OOB Write with Invalid PSD Tile Extents (Integer Overflow)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-09 · updated 2026-07-24
- Weakness: CWE-190
Description
Pillow is a Python imaging library. From version 10.3.0 to before version 12.2.0, processing a malicious PSD file could lead to memory corruption, potentially resulting in a crash or arbitrary code execution. This issue has been patched in version 12.2.0.
Affected products
- python-pillow Pillow: from 10.3.0 before 12.2.0 — fixed in 12.2.0
How to fix
Upgrade to a fixed version: python-pillow Pillow 12.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/python-pillow/Pillow/commit/58f9a1d166dcb0c274807d4423522d205b0c35ea
- https://github.com/python-pillow/Pillow/pull/9520
- https://github.com/python-pillow/Pillow/releases/tag/12.2.0
- https://github.com/python-pillow/Pillow/security/advisories/GHSA-pwv6-vv43-88gr
Get alerted when CVE-2026-42311 or the next vulnerability affects your stack