What’s Vulnerable › Vulnerabilities
CVE-2026-42334: Mongoose: Improper Sanitization of $nor in sanitizeFilter May Allow NoSQL Injection
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-10-26
- Weakness: CWE-74
Description
Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.9, 7.8.9, 8.22.1, and 9.1.6, a vulnerability allows bypassing Mongoose’s sanitizeFilter query sanitization mechanism via the $nor operator. When sanitizeFilter is enabled, Mongoose wraps query operators in $eq to neutralize them. However, prior to the fix, $nor was not included in the set of logical operators that are recursively sanitized. Because $nor accepts an array (like $and and $or), and arrays do not trigger hasDollarKeys(), malicious operators such as $ne, $gt, or $regex could be injected inside a $nor clause without being sanitized. This vulnerability is fixed in 6.13.9, 7.8.9, 8.22.1, and 9.1.6.
Affected products
- automattic/mongoose: before 6.13.9; from 7.0.0 before 7.8.9; from 8.0.0 before 8.22.1; from 9.0.0 before 9.1.6 — fixed in 6.13.9, 7.8.9, 8.22.1, 9.1.6
How to fix
Upgrade to a fixed version: automattic/mongoose 6.13.9, 7.8.9, 8.22.1, 9.1.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-42334 or the next vulnerability affects your stack