What’s Vulnerable › Vulnerabilities
CVE-2026-42354: Sentry: Improper authentication on SAML SSO process allows user identity linking
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-07-24
- Weakness: CWE-290
Description
Sentry is an error tracking and performance monitoring tool. From version 21.12.0 to before version 26.4.1, a critical vulnerability was discovered in the SAML SSO implementation of Sentry. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. This issue has been patched in version 26.4.1.
Affected products
- getsentry sentry: from 21.12.0 before 26.4.1 — fixed in 26.4.1
How to fix
Upgrade to a fixed version: getsentry sentry 26.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/getsentry/sentry/commit/0c67558ae7fe08738912d4c5233b53ead048da3b
- https://github.com/getsentry/sentry/pull/113720
- https://github.com/getsentry/sentry/releases/tag/26.4.1
- https://github.com/getsentry/sentry/security/advisories/GHSA-rcmw-7mc7-3rj7
Get alerted when CVE-2026-42354 or the next vulnerability affects your stack