What’s Vulnerable › Vulnerabilities
CVE-2026-42356: Apache HTTP Server: limited RCE for some internal redirects to non-CGI files in CGI directories
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-06
- Weakness: CWE-430
Description
Deployment of wrong handler vulnerability in Apache HTTP Server allows the target of some internal redirects from CGI programs to also be treated as CGI and executed. The target must already be in a directory enabled for CGI and have no other extension understood by mod_mime. This issue affects Apache HTTP Server: from 2.4.60 through 2.4.68.
Affected products
- Apache HTTP Server: from 2.4.0 before 2.4.69 — fixed in 2.4.69
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.69. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2026/10/01/11
Get alerted when CVE-2026-42356 or the next vulnerability affects your stack