What’s Vulnerable › Vulnerabilities
CVE-2026-4240: Open5GS CCA smf_s6b_sta_cb denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-16 · updated 2026-06-17
- Weakness: CWE-404
Description
A vulnerability was determined in Open5GS up to 2.7.6. The affected element is the function smf_gx_cca_cb/smf_gy_cca_cb/smf_s6b_aaa_cb/smf_s6b_sta_cb of the component CCA Handler. This manipulation causes denial of service. The attack can be initiated remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 2.7.7 is sufficient to fix this issue. Patch name: 80eb484a6ab32968e755e628b70d1a9c64f012ec. Upgrading the affected component is recommended.
Affected products
- Open5GS: before 2.7.7 — fixed in 2.7.7
How to fix
Upgrade to a fixed version: Open5GS 2.7.7. Check the vendor advisory for mitigations.
References
- https://github.com/open5gs/open5gs/
- https://github.com/open5gs/open5gs/commit/80eb484a6ab32968e755e628b70d1a9c64f012ec
- https://github.com/open5gs/open5gs/issues/4343
- https://github.com/open5gs/open5gs/issues/4343#issue-4021871895
- https://github.com/open5gs/open5gs/releases/tag/v2.7.7
- https://vuldb.com/?ctiid.351182
- https://vuldb.com/?id.351182
- https://vuldb.com/?submit.771361
Get alerted when CVE-2026-4240 or the next vulnerability affects your stack