What’s Vulnerable › Vulnerabilities
CVE-2026-42404: Apache Neethi: Unrestricted HTTP Redirect Following in Policy References
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-01 · updated 2026-10-26
- Weakness: CWE-918
Description
Apache Neethi does not impose any restrictions on URIs when manually fetching remote policy references through the PolicyReference API. When an application explicitly calls the API to retrieve a policy from a remote URI, an outbound request is made for arbitrary protocols and internal IP adddresses. From 3.2.2, only http or https URIs are allowed, and link-local/multicast/any-local addresses are forbidden. Users are recommended to upgrade to version 3.2.2, which fixes this issue.
Affected products
- Apache Software Foundation Apache Neethi: before 3.2.2 — fixed in 3.2.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Neethi 3.2.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/zdspnt64zznyjyn648553kptx69w23oq
- http://www.openwall.com/lists/oss-security/2026/05/01/8
Get alerted when CVE-2026-42404 or the next vulnerability affects your stack