What’s Vulnerable › Vulnerabilities
CVE-2026-42420: OpenClaw < 2026.4.8 - Improper Base64 Decoding Size Validation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-28 · updated 2026-06-17
- Weakness: CWE-770
Description
OpenClaw before 2026.4.8 contains improper input validation in base64 decode paths that allocate memory before enforcing decoded-size limits. Attackers can exploit multiple code paths to cause memory exhaustion or denial of service through crafted base64-encoded input.
Affected products
- OpenClaw: before 2026.4.8 — fixed in 2026.4.8
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.8. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/d7c3210cd6f5fdfdc1beff4c9541673e814354d5
- https://github.com/openclaw/openclaw/security/advisories/GHSA-ccx3-fw7q-rr2r
- https://www.vulncheck.com/advisories/openclaw-improper-base64-decoding-size-validation
Get alerted when CVE-2026-42420 or the next vulnerability affects your stack