What’s Vulnerable › Vulnerabilities
CVE-2026-42428: OpenClaw < 2026.4.8 - Missing Integrity Verification in Package Downloads
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-28 · updated 2026-06-17
- Weakness: CWE-353
Description
OpenClaw versions before 2026.4.8 fail to enforce integrity verification on downloaded plugin archives. Attackers can install malicious or tampered plugin packages without detection, compromising the local assistant environment.
Affected products
- OpenClaw: before 2026.4.8 — fixed in 2026.4.8
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.8. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/d7c3210cd6f5fdfdc1beff4c9541673e814354d5
- https://github.com/openclaw/openclaw/security/advisories/GHSA-3vvq-q2qc-7rmp
- https://www.vulncheck.com/advisories/openclaw-missing-integrity-verification-in-package-downloads
Get alerted when CVE-2026-42428 or the next vulnerability affects your stack