What’s Vulnerable › Vulnerabilities
CVE-2026-42429: OpenClaw < 2026.4.8 - Privilege Escalation via Gateway Plugin HTTP Authentication
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-28 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenClaw before 2026.4.8 contains a privilege escalation vulnerability in the gateway plugin HTTP authentication mechanism that escalates identity-bearing operator.read requests to runtime operator.write permissions. Attackers can exploit this by sending read-scoped requests through the gateway auth route to gain unauthorized write access to runtime operations.
Affected products
- OpenClaw: before 2026.4.8 — fixed in 2026.4.8
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.8. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/d7c3210cd6f5fdfdc1beff4c9541673e814354d5
- https://github.com/openclaw/openclaw/security/advisories/GHSA-4f8g-77mw-3rxc
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-gateway-plugin-http-authentication
Get alerted when CVE-2026-42429 or the next vulnerability affects your stack