What’s Vulnerable › Vulnerabilities
CVE-2026-42432: OpenClaw < 2026.4.8 - Command Escalation via Node Pairing Reconnect Bypass
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-28 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenClaw before 2026.4.8 contains a privilege escalation vulnerability allowing previously paired nodes to reconnect with exec-capable commands without the operator.admin scope requirement. Attackers can bypass re-pairing authentication to execute privileged commands on the local assistant system.
Affected products
- OpenClaw: before 2026.4.8 — fixed in 2026.4.8
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.8. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/d7c3210cd6f5fdfdc1beff4c9541673e814354d5
- https://github.com/openclaw/openclaw/security/advisories/GHSA-5wj5-87vq-39xm
- https://www.vulncheck.com/advisories/openclaw-command-escalation-via-node-pairing-reconnect-bypass
Get alerted when CVE-2026-42432 or the next vulnerability affects your stack