What’s Vulnerable › Vulnerabilities
CVE-2026-42437: OpenClaw 2026.4.9 < 2026.4.10 - Denial of Service via Oversized WebSocket Frames in Voice-call Realtime Path
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-05 · updated 2026-06-17
- Weakness: CWE-770
Description
OpenClaw versions 2026.4.9 before 2026.4.10 contain a denial of service vulnerability in the voice-call realtime WebSocket path that accepts oversized frames without proper validation. Remote attackers can send oversized WebSocket frames to cause service unavailability for deployments exposing the voice-call realtime WebSocket path.
Affected products
- OpenClaw: from 2026.4.9 before 2026.4.10 — fixed in 2026.4.10
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.10. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/afadb7dae6738819ad9c7d2597ace0516957d20e
- https://github.com/openclaw/openclaw/security/advisories/GHSA-vw3h-q6xq-jjm5
- https://www.vulncheck.com/advisories/openclaw-denial-of-service-via-oversized-websocket-frames-in-voice-call-realtime-path
Get alerted when CVE-2026-42437 or the next vulnerability affects your stack