What’s Vulnerable › Vulnerabilities
CVE-2026-42457: vCluster Platform: Stored XSS can lead to privilege escalation
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
vCluster Platform provides a Kubernetes platform for managing virtual clusters, multi-tenancy, and cluster sharing. Prior to 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0, there is a Stored XSS attack vulnerability via the name field of a templateRef. This can lead to the execution of arbitrary external scripts within the platform's browser context. In the worst case, a malicious user could potentially create a new Global-Admin user, bypassing other security restrictions. The attacker needs the ability to create namespaces. This vulnerability is fixed in 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0.
Affected products
- loft-sh loft: before 4.4.3; from 4.5.0-alpha.0 , < 4.5.5; from 4.6.0-alpha.1, < 4.6.2; from 4.7.0-alpha.0, < 4.7.1
References
Get alerted when CVE-2026-42457 or the next vulnerability affects your stack