What’s Vulnerable › Vulnerabilities
CVE-2026-4249: Denial of Service via Malicious JSON Payloads in Throttling Events in Multiple WSO2 Products Causing Persistent Service Disruption
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-06 · updated 2026-07-09
- Weakness: CWE-707
Description
The throttling event handling mechanism in multiple WSO2 products accepts user-supplied JSON payloads without sufficient validation of their structure and content. This allows an unauthenticated remote attacker to inject malicious JSON data that can lead to a persistent denial of service condition. Successful exploitation of this vulnerability can disrupt the API Gateway, preventing legitimate API traffic from being processed and impacting complete service availability. The denial of service is persistent, requiring manual intervention to restore normal operations.
Affected products
- WSO2 Api Control Plane: from 4.5.0 before 4.5.0.55; from 4.6.0 before 4.6.0.19 — fixed in 4.5.0.55, 4.6.0.19
- WSO2 API Manager: from 4.0.0 before 4.0.0.390; from 4.1.0 before 4.1.0.254; from 4.2.0 before 4.2.0.194; from 4.3.0 before 4.3.0.105; from 4.4.0 before 4.4.0.69; from 4.5.0 before 4.5.0.54 — fixed in 4.0.0.390, 4.1.0.254, 4.2.0.194, 4.3.0.105, 4.4.0.69, 4.5.0.54
- WSO2 Traffic Manager: from 4.5.0 before 4.5.0.53; from 4.6.0 before 4.6.0.18 — fixed in 4.5.0.53, 4.6.0.18
- WSO2 Universal Gateway: from 4.5.0 before 4.5.0.54; from 4.6.0 before 4.6.0.18 — fixed in 4.5.0.54, 4.6.0.18
How to fix
Upgrade to a fixed version: WSO2 Api Control Plane 4.5.0.55, 4.6.0.19; WSO2 API Manager 4.0.0.390, 4.1.0.254, 4.2.0.194, 4.3.0.105; WSO2 Traffic Manager 4.5.0.53, 4.6.0.18; WSO2 Universal Gateway 4.5.0.54, 4.6.0.18. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-4249 or the next vulnerability affects your stack