What’s Vulnerable › Vulnerabilities

CVE-2026-42509: Apache Wicket: crafted strings can break out of the JavaScript sequence

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Wicket 10.9.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-42509 or the next vulnerability affects your stack