What’s Vulnerable › Vulnerabilities
CVE-2026-42523
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-29 · updated 2026-10-26
- Weakness: CWE-79
Description
Jenkins GitHub Plugin 1.46.0 and earlier improperly processes the current job URL as part of JavaScript implementing validation of the feature "GitHub hook trigger for GITScm polling", resulting in a stored cross-site scripting (XSS) vulnerability exploitable by non-anonymous attackers with Overall/Read permission.
Affected products
- Jenkins Project Jenkins GitHub Plugin: before 1.46.0.1 — fixed in 1.46.0.1
How to fix
Upgrade to a fixed version: Jenkins Project Jenkins GitHub Plugin 1.46.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-42523 or the next vulnerability affects your stack