What’s Vulnerable › Vulnerabilities
CVE-2026-42528: Apache HTTP Server: mod_dav shared lock overflow
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-06
- Weakness: CWE-789
Description
A memory calculation bug in mod_dav in Apache httpd 2.4.67 and earlier allows an attacker with permission to create WebDAV locks to crash server child processes. Users are recommended to upgrade to version 2.4.69, which fixes this issue
Affected products
- Apache HTTP Server: from 2.4.0 before 2.4.69 — fixed in 2.4.69
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.69. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2026/10/01/12
Get alerted when CVE-2026-42528 or the next vulnerability affects your stack