What’s Vulnerable › Vulnerabilities
CVE-2026-42530: NGINX Open-Source ngx_http_v3_module vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-17 · updated 2026-10-26
- Weakness: CWE-416
Description
NGINX Open Source has a vulnerability in the ngx_http_v3_module module. When NGINX Open Source is configured to use the HTTP/3 QUIC module, a remote unauthenticated attacker along with conditions beyond their control can use a specially crafted HTTP/3 session to reopen a QPACK encoder stream. This may cause a Use-after-Free in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Gateway Fabric: from 1.3.0 through 1.6.2; from 2.0.0 before 2.6.4 — fixed in 2.6.4
- F5 NGINX Ingress Controller: from 3.5.0 through 3.7.2; from 5.0.0 before 5.5.1; 4.0.0, 4.0.1 — fixed in 5.5.1
- F5 NGINX Instance Manager: from 2.17.0 through 2.22.0
- F5 NGINX Open Source: from 1.31.0 before 1.31.2 — fixed in 1.31.2
How to fix
Upgrade to a fixed version: F5 NGINX Gateway Fabric 2.6.4; F5 NGINX Ingress Controller 5.5.1; F5 NGINX Open Source 1.31.2. Check the vendor advisory for mitigations.
References
- https://my.f5.com/manage/s/article/K000161616
- https://access.redhat.com/errata/RHSA-2026:20351
- https://access.redhat.com/security/cve/CVE-2026-42530
- https://bugzilla.redhat.com/show_bug.cgi?id=2489872
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42530.json
Get alerted when CVE-2026-42530 or the next vulnerability affects your stack