What’s Vulnerable › Vulnerabilities
CVE-2026-42533: NGINX Map directive and Regex matching vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-08-10
- Weakness: CWE-122
Description
A vulnerability exists in NGINX Plus and NGINX Open Source when a map directive uses regex matching and a string expression references the map's regex capture variables before referencing the map output variable. Alternatively, the same result could be achieved by using a non-cacheable variable in a string expression under certain conditions. An unauthenticated attacker along with conditions beyond their control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Impact: This vulnerability may allow remote attackers to cause a denial-of-service (DoS) on the NGINX system or to possibly trigger a code execution. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Gateway Fabric: from 1.3.0 through 1.6.2; from 2.0.0 before 2.6.7 — fixed in 2.6.7
- F5 NGINX Ingress Controller: from 3.5.0 through 3.7.2; from 5.0.0 before 5.5.3; from 2026-lts-r1 before 2026-lts-r4; 4.0.0, 4.0.1 — fixed in 2026-lts-r4, 5.5.3
- F5 NGINX Plus: from 37.0.0.1 before 37.0.3.1; from r33 before r36; r36, r36-p1, r36-p2, r36-p3, r36-p4, r36-p5 (+1) — fixed in 37.0.3.1, r36
- F5 Waf: from 4.11.0 through 4.16.0; from 5.2.0 through 5.8.0; from 5.9.0 before 5.13.4 — fixed in 5.13.4
How to fix
Upgrade to a fixed version: F5 NGINX Gateway Fabric 2.6.7; F5 NGINX Ingress Controller 2026-lts-r4, 5.5.3; F5 NGINX Plus 37.0.3.1, r36; F5 Waf 5.13.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-42533 or the next vulnerability affects your stack