What’s Vulnerable › Vulnerabilities

CVE-2026-42536: Apache HTTP Server: mod_xml2enc heap overflow

Description

Heap-based Buffer Overflow vulnerability in Apache HTTP Server with mod_xml2enc, xml2StartParse, and untrusted content This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 2.4.68. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-42536 or the next vulnerability affects your stack