What’s Vulnerable › Vulnerabilities
CVE-2026-42548: Flight: Reflected XSS via unvalidated JSONP callback in Flight::jsonp()
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-79
Description
Flight is an extensible micro-framework for PHP. Prior to 3.18.1, Flight::jsonp() concatenates the ?jsonp= query parameter directly into an application/javascript response body without validating that the value is a legal JavaScript identifier. An attacker can inject arbitrary JavaScript that executes in the response origin, enabling reflected cross-site scripting. This vulnerability is fixed in 3.18.1.
Affected products
- flightphp core: before 3.18.1
References
- https://github.com/flightphp/core/security/advisories/GHSA-fcx8-ph5r-mxr4
- https://github.com/flightphp/core/security/advisories/GHSA-fcx8-ph5r-mxr4
Get alerted when CVE-2026-42548 or the next vulnerability affects your stack