What’s Vulnerable › Vulnerabilities
CVE-2026-42550: Flight: SQL Injection via unvalidated identifiers in SimplePdo::insert / update / delete
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-89
Description
Flight is an extensible micro-framework for PHP. Prior to 3.18.1, SimplePdo::insert(), SimplePdo::update(), and SimplePdo::delete() build SQL statements by concatenating the $table argument and the keys of the $data array directly into the query, with no identifier quoting and no validation. When an application forwards user-controlled data shapes to these helpers — a common and documented pattern, e.g. $db->insert('users', $request->data->getData()) — an attacker can inject arbitrary SQL by crafting malicious array keys. This vulnerability is fixed in 3.18.1.
Affected products
- flightphp core: before 3.18.1
References
- https://github.com/flightphp/core/security/advisories/GHSA-xwqr-rcqg-22mr
- https://github.com/flightphp/core/security/advisories/GHSA-xwqr-rcqg-22mr
Get alerted when CVE-2026-42550 or the next vulnerability affects your stack