What’s Vulnerable › Vulnerabilities
CVE-2026-42551: Flight: HTTP method override enabled by default enables CSRF escalation and middleware bypass in flightphp/core
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-436
Description
Flight is an extensible micro-framework for PHP. Prior to 3.18.1, Request::getMethod() unconditionally honors the X-HTTP-Method-Override header and the $_REQUEST['_method'] parameter on any HTTP verb (including safe verbs such as GET), with no opt-in and no whitelist of permitted target methods. A GET request can silently become a DELETE or PUT, enabling CSRF escalation against destructive endpoints, bypass of middleware gated on unsafe verbs, and cache poisoning between CDN and origin. This vulnerability is fixed in 3.18.1.
Affected products
- flightphp core: before 3.18.1
References
- https://github.com/flightphp/core/security/advisories/GHSA-vxrr-w42w-w76g
- https://github.com/flightphp/core/security/advisories/GHSA-vxrr-w42w-w76g
Get alerted when CVE-2026-42551 or the next vulnerability affects your stack