What’s Vulnerable › Vulnerabilities
CVE-2026-42570: Svelte devalue: DoS via sparse array deserialization
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-08-24
- Weakness: CWE-770
Description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From version 5.6.3 to before version 5.8.1, devalue.parse could, due to quirks in some JavaScript engines, be convinced to allocate much more memory than was needed when deserializing sparse arrays, leading to excessive memory consumption. This issue has been patched in version 5.8.1.
Affected products
- sveltejs devalue: from 5.6.3 before 5.8.1 — fixed in 5.8.1
How to fix
Upgrade to a fixed version: sveltejs devalue 5.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/sveltejs/devalue/commit/206ca6712fbc380a4571c59de9ab04b91110792d
- https://github.com/sveltejs/devalue/releases/tag/v5.8.1
- https://github.com/sveltejs/devalue/security/advisories/GHSA-77vg-94rm-hx3p
- https://access.redhat.com/errata/RHSA-2026:37272
- https://access.redhat.com/errata/RHSA-2026:57590
- https://access.redhat.com/security/cve/CVE-2026-42570
- https://bugzilla.redhat.com/show_bug.cgi?id=2487050
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42570.json
Get alerted when CVE-2026-42570 or the next vulnerability affects your stack