What’s Vulnerable › Vulnerabilities

CVE-2026-42782: Apache Syncope: Post-auth RCE via Groovy static

Description

Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Syncope 4.0.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-42782 or the next vulnerability affects your stack