What’s Vulnerable › Vulnerabilities
CVE-2026-42789: Non-CA certificate accepted as intermediate issuer in public_key path validation
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-10-26
- Weakness: CWE-295
Description
Improper Following of a Certificate's Chain of Trust vulnerability in Erlang OTP public_key (pubkey_cert module) allows a non-CA certificate to be accepted as an intermediate issuer, enabling certificate chain forgery. In lib/public_key/src/pubkey_cert.erl, pubkey_cert:validate_extensions/7 contains two flaws that together allow a certificate with basicConstraints cA:false and no keyUsage extension to be used as an intermediate issuer in a chain passed to public_key:pkix_path_validation/3: the cA:false clause recurses into the remaining extensions without rejecting the certificate when it is in issuer position, and the keyUsage check only fires when the extension is present, so a certificate lacking keyUsage entirely bypasses the keyCertSign enforcement. Any party holding an end-entity certificate with basicConstraints cA:false and no keyUsage extension, issued by any CA in the victim's trust store, can use that certificate's private key to sign forged leaf certificates for arbitrary identities. public_key:pkix_path_validation/3 accepts the resulting chain, and by extension every TLS or mTLS endpoint built on the OTP ssl application that relies on the default verifier is affected, including server identity verification on the client side and client certificate verification on mTLS servers. This issue affects OTP from OTP 17.0 before OTP 27.3.4.19, OTP 28.5.0.8, and OTP 29.1.2, corresponding to public_key from 0.22 before 1.17.1.7, 1.20.3.6, and 1.21.8. Whether OTP before OTP 17.0, corresponding to public_key before 0.22, is affected is unknown.
Affected products
- Erlang OTP: from 17.0 before 26.2.5.21; from 27.0 before 27.3.4.12; from 28.0 before 28.5.0.1; from 29.0 before 29.0.1 — fixed in 26.2.5.21, 27.3.4.12, 28.5.0.1, 29.0.1
How to fix
Upgrade to a fixed version: Erlang OTP 26.2.5.21, 27.3.4.12, 28.5.0.1, 29.0.1. Check the vendor advisory for mitigations.
References
- https://cna.erlef.org/cves/CVE-2026-42789.html
- https://github.com/erlang/otp/commit/0a05b7ca33fb0b3f0a6cb9ae34252bb3a74032b8
- https://github.com/erlang/otp/commit/75ca4c0dc2bbdb286ac3c3fe89cb4b4d2b4dc333
- https://github.com/erlang/otp/commit/82af606b5437c4de1276dbcc8855a47e88231226
- https://github.com/erlang/otp/security/advisories/GHSA-c99q-jmpx-v8qq
- https://osv.dev/vulnerability/EEF-CVE-2026-42789
- https://www.erlang.org/doc/system/versions.html#order-of-versions
- https://access.redhat.com/errata/RHSA-2026:39809
- https://access.redhat.com/errata/RHSA-2026:54757
- https://access.redhat.com/security/cve/CVE-2026-42789
- https://bugzilla.redhat.com/show_bug.cgi?id=2482093
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42789.json
Get alerted when CVE-2026-42789 or the next vulnerability affects your stack