What’s Vulnerable › Vulnerabilities
CVE-2026-42796: Arelle < 2.39.10 Unauthenticated RCE via /rest/configure
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-04 · updated 2026-06-17
- Weakness: CWE-306
Description
Arelle before 2.39.10 contains an unauthenticated remote code execution vulnerability in the /rest/configure REST endpoint that accepts a plugins query parameter and forwards it to the plugin manager without authentication or authorization. Attackers can supply a URL to a malicious Python file through the plugins parameter, causing the Arelle webserver to download and execute the attacker-controlled code within the Arelle process with its privileges.
Affected products
- Arelle: before 2.39.10 — fixed in 2.39.10
How to fix
Upgrade to a fixed version: Arelle 2.39.10. Check the vendor advisory for mitigations.
References
- https://github.com/Arelle/Arelle/pull/2320
- https://github.com/Arelle/Arelle/releases/tag/2.39.10
- https://www.vulncheck.com/advisories/arelle-unauthenticated-rce-via-rest-configure
Get alerted when CVE-2026-42796 or the next vulnerability affects your stack