What’s Vulnerable › Vulnerabilities

CVE-2026-42797: Apache Syncope: JexlContextBuilder Information Disclosure

Description

Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Syncope 4.0.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-42797 or the next vulnerability affects your stack