What’s Vulnerable › Vulnerabilities
CVE-2026-42798
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-30 · updated 2026-10-26
- Weakness: CWE-190
Description
Little CMS (lcms2) 2.16 through 2.18 before 2.19 has an integer overflow in ParseCube in cmscgats.c.
Affected products
- littlecms little cms color engine: from 2.16 before 2.19 — fixed in 2.19
How to fix
Upgrade to a fixed version: littlecms little cms color engine 2.19. Check the vendor advisory for mitigations.
References
- https://github.com/mm2/Little-CMS/commit/6a686019825a89b715d16671f18d049523354176
- https://github.com/mm2/Little-CMS/compare/lcms2.18...lcms2.19
- https://www.openwall.com/lists/oss-security/2026/04/30/8
Get alerted when CVE-2026-42798 or the next vulnerability affects your stack