What’s Vulnerable › Vulnerabilities
CVE-2026-42851: @kitty-edit DCS + --color=geninclude vulnerable to Unauthenticated in-process RCE
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-12 · updated 2026-10-26
- Weakness: CWE-94
Description
Kitty is a cross-platform GPU based terminal. In versions prior to 0.47.0, a program able to write bytes to a kitty terminal — a remote SSH peer, a downloaded file viewed with `cat`, a log line, an email body rendered in `less`, an issue body in a TUI, etc. — can cause kitty to execute attacker-supplied Python inside the running kitty process, with the user's full privileges. There is no approval prompt, no remote-control permission requirement, no shell-integration interaction, no clipboard touch, and no editor interaction. Version 0.47.0 fixes the issue.
Affected products
- kovidgoyal kitty: before 0.47.0 — fixed in 0.47.0
How to fix
Upgrade to a fixed version: kovidgoyal kitty 0.47.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-42851 or the next vulnerability affects your stack