What’s Vulnerable › Vulnerabilities
CVE-2026-42887: Audiobookshelf: Stored Cross-Site Scripting in Login Page Custom Message
- Severity: medium (CVSS 4.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-10-26
- Weakness: CWE-79
Description
Audiobookshelf is a self-hosted audiobook and podcast server. Prior to 2.33.0, a stored cross-site scripting (XSS) vulnerability exists in the Login Page due to improper sanitization of the authLoginCustomMessage field of the /api/auth-settings endpoint. An attacker with administrative privileges can inject arbitrary HTML/JavaScript that will be rendered on the login page for all users. This vulnerability is fixed in 2.33.0.
Affected products
- advplyr audiobookshelf: before 2.33.0
References
- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-cx29-ghq2-9cm4
- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-cx29-ghq2-9cm4
Get alerted when CVE-2026-42887 or the next vulnerability affects your stack