What’s Vulnerable › Vulnerabilities
CVE-2026-4297: Welcome Software Publishing <= 0.0.31 - Authenticated (Subscriber+) Arbitrary Options Update to Privilege Escalation via 'nc.setOption' XML-RPC Method
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-06-25
- Weakness: CWE-862
Description
The Welcome Software Publishing plugin for WordPress is vulnerable to Arbitrary Options Update in all versions up to and including 0.0.31. This is due to a missing capability check in the nc_setOption() function, which is exposed via the nc.setOption XML-RPC method. The function authenticates the user via $wp_xmlrpc_server->login() (verifying credentials are valid) but does not perform any authorization check such as current_user_can('manage_options'). This makes it possible for authenticated attackers, with Subscriber-level access and above, to update arbitrary WordPress options via XML-RPC requests. This can be leveraged to change the default_role option to 'administrator' and then register a new administrator account, achieving full privilege escalation and site takeover.
Affected products
- newscred Welcome Software Publishing: through 0.0.31
References
- https://plugins.trac.wordpress.org/browser/newscred-publishing/tags/0.0.31/newscred.php#L264
- https://plugins.trac.wordpress.org/browser/newscred-publishing/tags/0.0.31/newscred.php#L265
- https://plugins.trac.wordpress.org/browser/newscred-publishing/tags/0.0.31/newscred.php#L272
- https://plugins.trac.wordpress.org/browser/newscred-publishing/tags/0.0.31/newscred.php#L44
- https://plugins.trac.wordpress.org/browser/newscred-publishing/trunk/newscred.php#L264
- https://plugins.trac.wordpress.org/browser/newscred-publishing/trunk/newscred.php#L265
- https://plugins.trac.wordpress.org/browser/newscred-publishing/trunk/newscred.php#L272
- https://plugins.trac.wordpress.org/browser/newscred-publishing/trunk/newscred.php#L44
- https://www.wordfence.com/threat-intel/vulnerabilities/id/47e53fd3-4e3f-433a-8e70-3a58c864184a?source=cve
Get alerted when CVE-2026-4297 or the next vulnerability affects your stack